Das Örtchen RSS-Feed
Kategorie
Kategorie: Blog
Buttons & Statistiken
Neueste Kommentare

Mozilla: Probleme mit Xmarks (Firefox)

Ich benutze zur Synchronisation meiner Firefox-Bookmarks das kostenlose Add-On Xmarks. Dieses speichert meine Lesezeichen als .json-Datei auf meinem eigenen FTP-Server. Jedenfalls war dies bis vor kurzem so, heute grinste mich bei jedem (auch manuellem) Synchronisations-Versuch ein rotes Fragezeichen an.

Das Problem

Zunächst öffnete ich die Xmarks-Einstellungen, weil ich dachte, daß eventuell die Account-Daten nicht mehr eingestellt seien. Aber diese waren da und unter Status wurde mir nur lapidar ein "Fehler beim Synchronisieren" gemeldet. Ich wechselte in die Lasche "Erweitert" und dort auf den Button "Protokolldatei anzeigen".

[2010-04-23 13:11:53] ------ Xmarks/3.6.14 (/Places) starting sync with ftp:// (...) ------
[2010-04-23 13:11:53] >>> GET ftp://benutzername [AT] www.example.com/foxmarks.json
[2010-04-23 13:11:54] Failed to parse message: (...)
[2010-04-23 13:11:54] >>> Callback ({status:1010, errormsg:"Invalid server response"})
[2010-04-23 13:11:54] Returned error: Server-Anfrage konnte nicht aufgelöst werden.(1010)
[2010-04-23 13:11:54] Will retry at Fri Apr 23 2010 13:27:07 GMT+0200

Die Recherche

Eine Suche mit Big G brachte nur einen Artikel von Thorsten auf netz-online.com. Im Gegensatz zu ihm hatte ich jedoch Version 3.6.14 installiert und eine abweichende Fehlermeldung. Der Vorschlag des Downgrades auf eine ältere Xmarks-Version hörte sich jedoch ganz brauchbar an und so installierte ich Version 3.5.10 aus meinem FEBE-Backup. Doch auch hiermit funktionierte das manuelle Synchronisieren leider nicht mehr.

Die Lösung

In Xmarks ist noch ein Link in den Support-Bereich des Herstellers versteckt. Dort gab ich dann die Meldung "Invalid server response" ein und erhielt eine entsprechende Supportmeldung. Direkt der erste Kommentar von Eric ("What seems to be happening is that your server file has been corrupted...") brachte mich dann auf die richtige Idee.

Ich löschte per FTP die .json-Datei und erzwang in Xmarks unter "Erweitert" das erneute "Hochladen" der Daten. Dies geschah immer noch mit Version 3.5.10 (dürfte aber nicht nötig sein). Danach klappte dann auch wieder das manuelle Synchronisieren mit der aktuellsten 3.6.15 (direkt vom Hersteller).

Hallo! Bist du neu hier? Dann abonniere doch den RSS-Feed dieses nicht mehr ganz so stillen Örtchens, um über meine geistigen Ergüsse auf dem Laufenden zu bleiben. Alternativ besteht auch die Möglichkeit, sich von FeedBurner per E-Mail über meine Ausscheidungen benachrichtigen zu lassen.

Neuen Kommentar schreiben

Der Inhalt dieses Feldes wird nicht öffentlich zugänglich angezeigt.
Der Inhalt dieses Feldes wird öffentlich zugänglich angezeigt, aber als rel="nofollow" markiert.
Hinweis

Kommentare beleben den Blog! Ich freue mich über jeden Kommentar. Du kannst hier offen Deine Meinung zum Artikel sagen, aber bitte beachte die Netiquette und vermeide es andere zu beleidigen.

Bitte unterlasst es die Kommentare zu SEO-Zwecken zu missbrauchen. Kommentare mit Links, die nicht zu Blogs führen (oder zu Blogs mit Grauzonen-Themen) und/oder Keywords als Namen verwenden, sind nicht erwünscht!

Möchtest Du mir einen Blog-Artikel schmackhaft machen, dann schreib die URL ohne HTML-Tag in den Kommentarbereich und ich werde diesen bei Gefallen verlinken.